EN FR

Pacman: use regex to install multiple packages

Say I want to install all the packages starting with 'festival'. Using a wildcard throws an error, as well as using a regex, quoted or not:

$ sudo pacman -S festival*
error: target not found: festival*
$ sudo pacman -S 'festival.*'
error: target not found: festival.*
$ sudo pacman -S '^festival'
error: target not found: ^festival

And it is perfectly normal... since this is not implemented!

One solution is to pipe the result of a search query, which does support regex:

$ pacman -Ssq '^festival' | sudo pacman -S -
resolving dependencies...
looking for conflicting packages...

Packages (3) festival-2.1-5  festival-english-2.4-1  festival-us-2.4-1
[...]

"Upgrade to Firefox" bannerSupport La Quadrature du Net!Soutenir FramasoftSupport the Gooseberry project, Blender Foundation's 5th Open Movie project